现在的位置: 首页 > 综合 > 正文

HDU 3123 数论

2017年11月22日 ⁄ 综合 ⁄ 共 1537字 ⁄ 字号 评论关闭

 

GCC

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1888    Accepted Submission(s): 596

Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication,
not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

 

Sample Input
1 10 861017
 

Sample Output
593846
 

Source
 
题目很水
那个n是用来吓人的。其实仔细想想会知道,当n比m还大的时候n!%m=0
于是后面比m大的全都是没有用的数据
 
于是只需要处理比m小得那些数的阶乘对m取余,然后用__int64存一下结果
没啥好说的
 
我的代码:
#include<stdio.h>
#include<string.h>

typedef __int64 ll;

ll sum[1000000];

ll change(char *s)
{
	ll l,i,res=0;
	l=strlen(s);
	for(i=0;i<l;i++)
		res=res*10+(s[i]-'0');
	return res;
}

int main()
{
	ll i,t,n,m,l;
	char s[105];
	scanf("%I64d",&t);
	while(t--)
	{
		scanf("%s%I64d",s,&m);
		l=strlen(s);
		if(l<7)
		{
			n=change(s);
			if(n>=m)
				n=m-1;
			sum[0]=1;
			ll ans=0;
			for(i=1;i<=n;i++)
			{
				sum[i]=(sum[i-1]*i)%m;
				ans=(ans+sum[i])%m;
			}
			printf("%I64d\n",(ans+1)%m);
		}
		else
		{
			n=m-1;
			sum[0]=1;
			ll ans=0;
			for(i=1;i<=n;i++)
			{
				sum[i]=(sum[i-1]*i)%m;
				ans=(ans+sum[i])%m;
			}
			printf("%I64d\n",(ans+1)%m);
		}
	}
	return 0;
}

抱歉!评论已关闭.