现在的位置: 首页 > 综合 > 正文

657 – The die is cast

2018年01月12日 ⁄ 综合 ⁄ 共 3839字 ⁄ 字号 评论关闭

The die is cast 

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty
popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their
users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if
they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence $a_1, a_2, \dots, a_k$ inS such
that a = a1 and b = ak , and ai and ai+1 are connected for $1 \le i < k$.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected.
Likewise we consider every maximal connected set of dot pixels to form a dot.

Input 

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy$5 \leŸw,h \le 50$.

The following h lines contain w characters each. The characters can be: ``.'' for a background pixel, ``*'' for a pixel of a die, and ``X'' for a pixel of a die's dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output 

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

Sample Input 

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

Sample Output 

Throw 1
1 2 2 4

这道题的意思就是,有一块图。其中呢用*和X组成的为一个照片,然后在这些照片当中找出有多少个X块。其中前后左右相连的X为一块。

这道题其实就是做两个DFS。可以用两个数组来分别标记照片和X块。之前由于没有注意到一开始的搜索的时候就可能碰到X。wa了好多次。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
char map[60][60];
int visit[60][60],w,h,s[400],p=0,v[60][60];
int dir[8][2]= {{-1,0},{0,-1},{0,1},{1,0},{-1,-1},{1,1},{-1,1},{1,-1}};
int in(int x, int y)
{
    if (x>=0 && x<w && y>=0 && y<h) return 1;
    return 0;
}
int bfs2(int x, int y)//实现X块的搜索
{
    int nx,ny,i;
    for (i=0; i<4; i++)
    {
        nx=x+dir[i][0];
        ny=y+dir[i][1];
        if (!v[nx][ny] && in(nx,ny) && map[nx][ny]=='X')
        {
            v[nx][ny]=1;
            bfs2(nx,ny);
        }
    }
}
int bfs1(int x, int y)//对照片进行搜索
{
    int nx,ny,i;
    for (i=0; i<4; i++)
    {
        nx=x+dir[i][0];
        ny=y+dir[i][1];
        if (!visit[nx][ny] && in(nx,ny) && map[nx][ny]!='.')
        {
            visit[nx][ny]=1;
            if (map[nx][ny]=='X' && !v[nx][ny])//对X块搜索
            {
                v[nx][ny]=1;
                s[p]++;
                bfs2(nx,ny);
            }
            bfs1(nx,ny);
        }
    }
}
int main ()
{
    int t=1,i,j;
    while(cin>>h>>w)
    {
        p=0;
        memset(visit,0,sizeof(visit));
        memset(s,0,sizeof(s));
        memset(v,0,sizeof(v));
        if (w==0) break;
        for (i=0; i<w; i++)
            for (j=0; j<h; j++)
                cin>>map[i][j];
        for (i=0; i<w; i++)
            for (j=0; j<h; j++)
            {
                if (!visit[i][j] && map[i][j]!='.')
                {
                    visit[i][j]=1;
                    if (map[i][j]=='X')//要注意一开始就有可能碰到X 马上进行bfs2
                    {
                        v[i][j]=1;
                        bfs2(i,j);
                        s[p]++;
                    }
                    bfs1(i,j);
                    p++;
                }
            }
        printf("Throw %d\n",t++);
        sort(s,s+p);
        for (i=0; i<p-1; i++)
            cout<<s[i]<<" ";
        cout<<s[p-1]<<endl<<endl;
    }
    return 0;
}

抱歉!评论已关闭.