现在的位置: 首页 > 综合 > 正文

839 – Not so Mobile

2018年01月12日 ⁄ 综合 ⁄ 共 2204字 ⁄ 字号 评论关闭

  Not so Mobile 

Before being an ubiquous communications gadget, a mobile was just a structure made of strings and wires suspending colourfull things. This kind of mobile is usually found hanging over cradles of small babies.

\epsfbox{p839a.eps}

The figure illustrates a simple mobile. It is just a wire, suspended by a string, with an object on each side. It can also be seen as a kind of lever with the fulcrum on the point where the string ties the wire.
From the lever principle we know that to balance a simple mobile the product of the weight of the objects by their distance to the fulcrum must be equal. That is Wl×Dl = Wr×Dr where Dl is
the left distance, Dr is the right distance, Wl is the
left weight and Wr is the right weight.

In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure. In this case it is not so straightforward to check if the mobile is balanced so we need you to write a program that, given a description of a mobile as input,
checks whether the mobile is in equilibrium or not.

\epsfbox{p839b.eps}

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank
line between two consecutive inputs.

The input is composed of several lines, each containing 4 integers separated by a single space. The 4 integers represent the distances of each object to the fulcrum and their weights, in the format: Wl Dl Wr Dr

If Wl or Wr is
zero then there is a sub-mobile hanging from that end and the following lines define the the sub-mobile. In this case we compute the weight of the sub-mobile as the sum of weights of all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are
zero then the following lines define two sub-mobiles: first the left then the right one.

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

Write `YES' if the mobile is in equilibrium, write `NO' otherwise.

Sample Input 

1

0 2 0 4
0 3 0 1
1 1 1 1
2 4 4 2
1 6 3 2

Sample Output 

YES

由于二叉树的建立可以用递归来实现。所以和二叉树相关的题目,都能够读出递归的味道。

这道题是一个系统,要求能够达到杠杆平衡。每一组为一个单位,那其左侧和右侧有可以再次分为两个小的平衡体来做。

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
using namespace std;
bool uq=true;
int input()
{
    int w1,d1,w2,d2;
    cin>>w1>>d1>>w2>>d2;
    if (w1==0)
        w1+=input();
    if (w2==0)
        w2+=input();
    if (w1*d1!=w2*d2) uq=false;
    return w1+w2;
}
int main ()
{
    int n;
    cin>>n;
    while(n--)
    {
        uq=true;
        input();
        if (uq) cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
        if (n!=0) cout<<endl;
    }
}

抱歉!评论已关闭.