现在的位置: 首页 > 综合 > 正文

POJ 2031 Building a Space Station

2018年01月12日 ⁄ 综合 ⁄ 共 3877字 ⁄ 字号 评论关闭
Building a Space Station
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 3705   Accepted: 1884

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is
quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or
(3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least
three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with
the shortest total length of the corridors. 

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form
a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 


x1 y1 z1 r1 
x2 y2 z2 r2 
... 
xn yn zn rn 

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after
the decimal point. Values are separated by a space character. 

Each of x, y, z and r is positive and is less than 100.0. 

The end of the input is indicated by a line containing a zero. 

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834



题意:有n个球形空间站,给出坐标以及半径。当两个球形空间站相交或者相切时,表示连通。如果两个没有连通的空间站之间加一个走廊便可以连通。求最少需要多长的走廊。

说白了就是最小生成树。不过数据给的比较隐晦。可以先处理处map[ ][ ]来。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
using namespace std;
double map[105][105]= {0};
double sta[105][4]= {0};
int n;
void prime()
{
    double low[105],ans=0;
    int i,j,k,visit[105]={0};
    for (i=1; i<=n; i++)
        low[i]=map[1][i];
    visit[1]=1;
    for (i=1; i<n; i++)
    {
        double max=100000.0;
        for (j=1; j<=n; j++)
            if (!visit[j] && low[j]<max)
            {
                max=low[j];
                k=j;
            }
        ans+=low[k];
        visit[k]=1;
        for (j=1; j<=n; j++)
            if (!visit[j] && low[j]>map[k][j])
                low[j]=map[k][j];
    }
    printf("%.3f\n",ans);
    return;
}
int main ()
{
    int i,j;
    while(cin>>n)
    {
        if (n==0) break;
        for (i=1; i<=n; i++)
            scanf("%lf%lf%lf%lf",&sta[i][0],&sta[i][1],&sta[i][2],&sta[i][3]);
        for (i=1; i<=n; i++)
            for (j=1; j<=n; j++)//一开始给map赋值的时候 j=i了。。
            {
                double s=0,v;
                for (int k=0; k<3; k++)
                    s+=(sta[i][k]-sta[j][k])*(sta[i][k]-sta[j][k]);
                v=sta[i][3]+sta[j][3];
                s=sqrt(s);
                if (s-v<1e-9) map[i][j]=0;
                else map[i][j]=map[j][i]=(s-v);
            }
        prime();
    }
    return 0;
}

抱歉!评论已关闭.