现在的位置: 首页 > 综合 > 正文

POJ 1861 Network

2018年01月12日 ⁄ 综合 ⁄ 共 2392字 ⁄ 字号 评论关闭
Network
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 12067   Accepted: 4652   Special Judge

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network,
each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one
because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about
possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot
be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding
cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

题意:
其实就是求最小生成树,并且使得最大边最小。
用krusical算法可以直接得到最小的最大边
不过一开始看样例的时候被吓了。。不是最小生成树么,怎么成环了。。。
诶。。被万恶的Special Judge给欺骗了。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
using namespace std;
struct node
{
    int x,y,s,u;
}e[15010]={0};
bool cmp(node s, node v)
{
    return s.s<v.s;
}
int n,m,f[1010]={0};
int find(int x)
{
    if (x==f[x]) return x;
    f[x]=find(f[x]);
    return f[x];
}
int krusical()
{
    int i,j,t=0,x,y;
    for (i=0; i<m; i++)
    {
        x=find(e[i].x);
        y=find(e[i].y);
        if (x!=y)
        {
            e[i].u=1;
            f[x]=f[y];
            t++;
        }
        if (t==n-1) break;
    }
    return i;
}
int main ()
{
    int i,j;
    cin>>n>>m;
    for (i=0; i<m; i++)
        scanf("%d %d %d",&e[i].x,&e[i].y,&e[i].s);
    sort(e,e+m,cmp);
    for (i=1; i<=n; i++)
        f[i]=i;
    i=krusical();
    cout<<e[i].s<<endl;
    cout<<n-1<<endl;
    for (j=0; j<=i; j++)
        if (e[j].u)
            cout<<e[j].x<<" "<<e[j].y<<endl;
    return 0;
}

抱歉!评论已关闭.