现在的位置: 首页 > 综合 > 正文

HDOJ 1702 ACboy needs your help again! (STL 栈 队列)

2018年01月12日 ⁄ 综合 ⁄ 共 2463字 ⁄ 字号 评论关闭


ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2452 Accepted Submission(s): 1254

Problem Description
ACboy was kidnapped!! he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."The problems of the monster is shown on the wall:Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").and the following N lines, each line is "IN M" or "OUT", (M represent a integer).and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
Input
The input contains multiple test cases.The first line has one integer,represent the number oftest cases.And the input of each subproblem are described above.
Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
Sample Input
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT

Sample Output
1 2 2 1 1 2 None 2 3
STL的应用
贴一下队列和栈的基本用法
代码:
#include<iostream>
#include<queue>
#include<stack>
#include<cstdio>
#include<cstring>
#include<ctype.h>
using namespace std;
int n;
void FIFO ()
{
    queue<int> ss;
    char ch[10];
    int p,i;
    for (i=0; i<n; i++)
    {
        scanf("%s", ch);
        if (strcmp(ch,"IN")==0)
        {
            cin>>p;
            ss.push(p);
        }
        else
        {
            if (!ss.empty())
            {
                cout<<ss.front()<<endl;
                ss.pop();
            }
            else
                cout<<"None"<<endl;
        }
    }
    return;
}
void FILO ()
{
    stack<int> ss;
    char ch[10];
    int p,i;
    for (i=0; i<n; i++)
    {
        scanf("%s", ch);
        if (strcmp(ch,"IN")==0)
        {
            cin>>p;
            ss.push(p);
        }
        else
        {
            if (!ss.empty())
            {
                cout<<ss.top()<<endl;
                ss.pop();
            }
            else
                cout<<"None"<<endl;
        }
    }
    return;
}
int main ()
{
    int t,i;
    string st;
    char ch[10];
    cin>>t;
    while (t--)
    {
        cin>>n;
        cin>>st;
        if (st=="FIFO")
            FIFO();
        else if (st=="FILO")
            FILO();
    }
    return 0;
}






0
0

抱歉!评论已关闭.