现在的位置: 首页 > 综合 > 正文

HDOJ 1509 Windows Message Queue (优先队列)

2018年01月12日 ⁄ 综合 ⁄ 共 1772字 ⁄ 字号 评论关闭

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2346 Accepted Submission(s): 910

Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue.
Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting
messages to and getting message from the message queue.

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter
and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET

Sample Output
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
解题思路:
优先队列的一个运用。贴一下代码吧
代码:
#include <cstdio>
#include <queue>
#include <iostream>
#include <string>
#include <cstring>
using namespace std;
struct node
{
    string s;
    int m,n,i;
    friend bool operator<(const node &aa,const node &bb)
    {
        if(aa.n==bb.n)
            return aa.i>bb.i;
        return aa.n>bb.n;
    }
};
int main()
{
    int k=0;
    node aa;
    priority_queue<node> q;
    char str[10];
    while (cin>>str)
    {
        if(str[0]=='G')
        {
            if(!q.empty())
            {
                aa=q.top();
                q.pop();
                cout<<aa.s<<" "<<aa.m<<endl;
            }
            else
                cout<<"EMPTY QUEUE!"<<endl;
        }
        else
        {
            cin>>aa.s>>aa.m>>aa.n;
            aa.i=k++;
            q.push(aa);
        }
    }
}

抱歉!评论已关闭.