现在的位置: 首页 > 综合 > 正文

408 – Uniform Generator

2018年01月12日 ⁄ 综合 ⁄ 共 2414字 ⁄ 字号 评论关闭

 Uniform Generator 

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

displaymath29

where `` tex2html_wrap_inline31 " is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order
to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including
0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the sameseed(x+1) every time seed(x) occurs means that if a function will generate
all the numbers between 0 andMOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because
no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input

Each line of input will contain a pair of integers for STEP and MOD in that order ( tex2html_wrap_inline77 ).

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either ``Good Choice"
or ``Bad Choice" left-justified starting in column 25. The ``Good Choice" message should be printed when the selection of STEP andMOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers
are generated. Otherwise, your program should print the message ``Bad Choice". After each output test set, your program should print exactly one blank line.

Sample Input

3 5
15 20
63923 99999

Sample Output

         3         5    Good Choice

        15        20    Bad Choice

     63923     99999    Good Choice

题意:一个step,一个mod,每次从0开始,(0+step)%mod=t,(t+step)%mod=t。如此循环。知道出现循环,问这些 t 能否包含从0到mod-1内的所有数

我一上来就直接暴力解决了。。过了。不过要是数据再大,或者时间控制的更加严格。这种方法就不实际了

后来看了别人的结题报告,说如果两个数的最大公约数不是1.就不能组成。否则就可以

具体证明比较简单。大家有兴趣可以研究一下

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
long long a[10000010];
int main ()
{
    int i,step,mod;
    while(cin>>step>>mod)
    {
        for (i=0; i<=mod; i++)
            a[i]=0;
        a[0]=1;
        int sum=1;
        int t=0;
        while(1)
        {
            t=(t+step)%mod;
            if (!a[t])
            {
                a[t]=1;
                sum++;
            }
            else break;
        }
        if (sum==mod) printf("%10d%10d    Good Choice\n",step,mod);
        else printf("%10d%10d    Bad Choice\n",step,mod);
        cout<<endl;
    }
    return 0;
}

抱歉!评论已关闭.