现在的位置: 首页 > 综合 > 正文

568 – Just the Facts

2018年01月12日 ⁄ 综合 ⁄ 共 1341字 ⁄ 字号 评论关闭


  Just the Facts 

The expression N!, read as ``N factorial,"
denotes the product of the first 
N positive integers, where N is
nonnegative. So, for example,

N N!
0 1
1 1
2 2
3 6
4 24
5 120
10 3628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ($0 \le N \le 10000$).
For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer N,
you should read the value and compute the last nonzero digit of 
N!.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the value N,
right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain ``
 -> " (space hyphen greater space). Column 10 must contain the single last non-zero
digit of 
N!.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8

题意:给你n,让你求出n!从各位开始的第一个非零的数

这道题如果直接暴力计算,必然会超。因为只要求要个位,所以其实可以稍做处理,把一些必然无关紧要的给省略了。

还有就是,不能每次都只保存个位。因为有可能个位乘以n之后,进位之后就不对了。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int a[10010]= {0};
int main ()
{
    int i,n,fa=1;
    a[0]=1;
    for (i=1; i<=10000; i++)
    {
        a[i]=a[i-1]*i;
        while(a[i]%10==0)
            a[i]=a[i]/10;//这里就是把0给去掉
        a[i]=a[i]%100000;//这里要取多几位
    }
    while(cin>>n)
        printf("%5d -> %d\n",n,a[n]%10);
    return 0;
}

抱歉!评论已关闭.