现在的位置: 首页 > 综合 > 正文

575 – Skew Binary

2018年01月12日 ⁄ 综合 ⁄ 共 1329字 ⁄ 字号 评论关闭

  Skew Binary 

When a number is expressed in decimal, the k-th digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example, 

\begin{displaymath}81307_{10} = 8 \times 10^4 + 1 \times 10^3 + 3 \times 10^2 + ......mes 10^1 +7 \times 10 0 = 80000 + 1000 + 300 + 0 + 7= 81307.\end{displaymath}


When a number is expressed in binary, the k-th digit represents a multiple of 2k. For example, 

\begin{displaymath}10011_2 = 1 \times 2^4 + 0 \times 2^3 + 0 \times 2^2 + 1 \times 2^1 +1 \times 2^0 = 16 + 0 + 0 + 2 + 1 = 19.\end{displaymath}


In skew binary, the k-th digit represents a multiple of 2k+1 - 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For
example, 

\begin{displaymath}10120_{skew} = 1 \times (2^5 - 1) + 0 \times (2^4-1) + 1 \tim......2 \times (2^2-1) + 0 \times (2^1-1)= 31 + 0 + 7 + 6 + 0 = 44.\end{displaymath}


The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to
do with the current problem.)

Input 

The input file contains one or more lines, each of which contains an integer n. If n =
0 it signals the end of the input, and otherwise 
n is a nonnegative integer in skew binary.

Output 

For each number, output the decimal equivalent. The decimal value of n will be at most 231 -
1 = 2147483647.

Sample Input 

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0

Sample Output 

44
2147483646
3
2147483647
4
7
1041110737

给你一个数,是按照一个特殊的进制规格的。其中k位上代表了2^(k+1) -1 。然后就是求出十进制。水题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int main ()
{
    char skew[50];
    int sum,i;
    while(cin>>skew)
    {
        sum=0;
        if (strcmp(skew,"0")==0) break;
        int len=strlen(skew);
        for (i=len-1; i>=0; i--)
            sum+=(skew[i]-'0')*(pow(2,len-i)-1);
        cout<<sum<<endl;
    }
    return 0;
}

抱歉!评论已关闭.