现在的位置: 首页 > 综合 > 正文

10790 – How Many Points of Intersection?

2018年01月12日 ⁄ 综合 ⁄ 共 1478字 ⁄ 字号 评论关闭

  How Many Points of Intersection? 

We have two rows. There are a dots on the top row and b dots
on the bottom row. We draw line segments connecting every dot on the top row with every dot on the bottom row. The dots are arranged in such a way that the number of internal intersections among the line segments is maximized. To achieve this goal we must
not allow more than two line segments to intersect in a point. The intersection points on the top row and the bottom are not included in our count; we can allow more than two line segments to intersect on those two rows. Given the value of a and b,
your task is to compute P(ab), the number of intersections in between the two rows. For example, in the following figure a =
2
 and b = 3. This figure illustrates that P(2, 3) = 3.

\epsfbox{p10790.eps}

Input 

Each line in the input will contain two positive integers a ( 0
a$ \le$20000
) and b ( 0
b$ \le$20000
). Input is terminated by a line where both a and b are
zero. This case should not be processed. You will need to process at most 1200 sets of inputs.

Output 

For each line of input, print in a line the serial of output followed by the value of P(ab).
Look at the output for sample input for details. You can assume that the output for the test cases will fit in 64-bitsigned integers.

Sample Input 

2 2
2 3
3 3
0 0

Sample Output 

Case 1: 1
Case 2: 3
Case 3: 9

这道题没什么好说的,有个公式:a*(a-1) * b * (b -1)/4

要注意数据的范围。int型在运算的过程如果超过了int型,不能直接赋值给long long。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<ctype.h>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
int main ()
{
    long long a,b;
    int p=1;
    long long t;
    while(cin>>a>>b)
    {
        if (a==0) break;
        t=a*(a-1)*b*(b-1)/4;
        printf("Case %d: %lld\n",p,t);
        p++;
    }
    return 0;
}

抱歉!评论已关闭.