现在的位置: 首页 > 综合 > 正文

【KMP】 hdu3613 Best Reward

2018年01月14日 ⁄ 综合 ⁄ 共 2648字 ⁄ 字号 评论关闭

Best Reward

http://acm.hdu.edu.cn/showproblem.php?pid=3613



Problem Description
After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to
cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones'
value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

 


Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v1, the value of 'b' is v2, ..., and so on.
The length of the string is no more than 500000. 

 


Output
Output a single Integer: the maximum value General Li can get from the necklace.
 


Sample Input
2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 aba 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 acacac
 


Sample Output
1 6


题意:小写字母组成的长n的串, 每种字母有一定的价值(可以为负), 要你分成切成两个串, 总价值为两个串价值和, 若是回文, 则串的价值为每个字母价值和, 否则为0。 问最大价值多少。

题解:把原串反转接在原串后, 中间夹个#, 然后做KMP, 于是末尾的next就指向了原串的最长回文前缀的末尾.(具体可以看http://roba.rushcj.com/?p=439),接着把前面的原串再反转,
再做一次KMP, 就找到了所有回文后缀,最后
只要线性扫一遍找最大值即可.

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define MAX 500005
char s[MAX<<1];
int nextx[MAX<<1],value[30];
int summ[MAX],v[2][MAX];
int n,m;
void get_nextx()
{
    int i=0,j=-1;
    nextx[0]=-1;
    for(;i<m;)
        if(j==-1||s[i]==s[j])
        {
            ++i;++j;
            nextx[i]=j;
        }
        else j=nextx[j];
}
void check(int x)
{
    summ[0]=0;
    for(int i=0;i<n;++i)
        summ[i+1]=summ[i]+value[s[i]-'a'];
    reverse_copy(s,s+n,s+n+1);
    s[n]='#';
    get_nextx();
    memset(v[x],0,sizeof(v[x]));
    int p=m;
    for(;;)
    {
        p=nextx[p];
        if(!~p) break;
        v[x][p]=summ[p];
    }
}
int main()
{
    int cas;
    scanf("%d",&cas);
    for(;cas--;)
    {
        int ans=-((1<<25)-1);
        for(int i=0;i<26;++i) scanf("%d",&value[i]);
        scanf("%s",s);
        n=strlen(s);
        m=2*n+1;
        check(0);
        reverse(s,s+n);
        check(1);
        reverse(v[1],v[1]+n+1);
        for(int i=1;i<n;++i)
            ans=max(ans,v[0][i]+v[1][i]);
        printf("%d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.