现在的位置: 首页 > 综合 > 正文

【KMP】 poj2752 Seek the Name, Seek the Fame

2018年01月14日 ⁄ 综合 ⁄ 共 1486字 ⁄ 字号 评论关闭
Seek the Name, Seek the Fame

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative
little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;
char s[400005];
int next[400005];
stack<int> st;
void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    for(;s[i];)
       if(j==-1||s[i]==s[j])
       {
           ++i;
           ++j;
           next[i]=j;
       }
       else j=next[j];
}
int main()
{
    for(;~scanf("%s",s);)
    {
        get_next();
        for(int i=next[strlen(s)];i>=1;i=next[i])
           st.push(i);
        for(;!st.empty();st.pop())
           printf("%d ",st.top());
        printf("%d\n",strlen(s));
    }
    return 0;
}

抱歉!评论已关闭.