现在的位置: 首页 > 综合 > 正文

【KMP】 poj1961 Period

2018年01月14日 ⁄ 综合 ⁄ 共 1497字 ⁄ 字号 评论关闭
Period

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is
one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing
order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题目:给定字符串S,求其前n位重复的次数。比如aabaabaabaab,前2位是aa,a重复了2次,前6位是aabaab,aab重复了2次,前9位是aabaabaab,aab重复了3次,前12位是aabaabaabaab,aab重复了4次。

所以输出的结果就是

2 2
6 2
9 3
12 4

题解:通过KMP求循环节长度,然后枚举每个点判断。


#include<cstdio>
#include<cstring>
using namespace std;
char s[1000005];
int next[1000005];
void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    for(;s[i];)
        if(j==-1||s[i]==s[j])
        {
            ++i;
            ++j;
            next[i]=j;
        }
        else
           j=next[j];
}
int main()
{
    int t,n;
    for(int cas=1;scanf("%d",&n),n;++cas)
    {
        scanf("%s",s);
        get_next();
        printf("Test case #%d\n",cas);
        for(int i=1;i<=n;++i)
            if(i%(i-next[i])==0)
               if(i/(i-next[i])>1)
                  printf("%d %d\n",i,i/(i-next[i]));
        printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.