现在的位置: 首页 > 综合 > 正文

【字典树】 hdu1671 Phone List

2018年01月14日 ⁄ 综合 ⁄ 共 2391字 ⁄ 字号 评论关闭

Phone List

http://acm.hdu.edu.cn/showproblem.php?pid=1671



Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 


Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number
is a sequence of at most ten digits.
 


Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 


Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 


Sample Output
NO YES

题意:给出一些电话号码,问是否存在某些电话号码是其他号码的前缀,存在则输出NO,反之则YES

题解:字典树,加入号码的时候就判断是否在自己的前缀上已经有其他号码了,如果没有,之后再全部判断一次(也有可能前缀是之后再加入树中的)。

ps:poj也有这一题,好像是一定要静态的字典树才能过。

动态字典树:

#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
    node *next[10];
    int id;
    node()
    {
        memset(next,0,sizeof(next));
        id=0;
    }
}*head;
bool flag;
char s[10005][15];
void f(node *head)
{
    for(int i=0;i<10;++i)
        if(head->next[i]!=NULL) f(head->next[i]);
    delete(head);
}
void build(char *t,node *head,int id)
{
    int len=strlen(t),k;
    for(int i=0;i<len;++i)
    {
        k=t[i]-'0';
        if(head->next[k]==NULL)
           head->next[k]=new node();
        if((head->id)&&(head->id!=id))
            flag=false;
        head=head->next[k];
    }
    head->id=id;
}
int main()
{
    int cas,n;
    scanf("%d",&cas);
    for(;cas--;)
    {
        head=new node();
        flag=true;
        scanf("%d",&n);
        for(int i=1;i<=n;++i)
        {
            scanf("%s",s[i]);
            build(s[i],head,i);
        }
        if(flag==false)
        {
            puts("NO");
            f(head);
            continue;
        }
        for(int i=1;i<=n;++i)
        {
            build(s[i],head,i);
            if(flag==false) break;
        }
        if(flag) puts("YES");
        else     puts("NO");
        f(head);
    }
    return 0;
}

静态字典树:

#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
    int next[10];
    int id;
}head[100005];
bool flag;
int cnt;
char s[10005][15];
void build(char *t,int idx,int id)
{
    int len=strlen(t),k;
    for(int i=0;i<len;++i)
    {
        k=t[i]-'0';
        if(head[idx].next[k]==0)
           head[idx].next[k]=(cnt++);
        if((head[idx].id)&&(head[idx].id!=id))
            flag=false;
        idx=head[idx].next[k];
    }
    head[idx].id=id;
}
int main()
{
    int cas,n;
    scanf("%d",&cas);
    for(;cas--;)
    {
        flag=true;
        cnt=1;
        scanf("%d",&n);
        memset(head,0,sizeof(head));
        for(int i=1;i<=n;++i)
        {
            scanf("%s",s[i]);
            build(s[i],0,i);
        }
        if(flag==false)
        {
            puts("NO");
            continue;
        }
        for(int i=1;i<=n;++i)
        {
            build(s[i],0,i);
            if(flag==false) break;
        }
        if(flag) puts("YES");
        else     puts("NO");
    }
    return 0;
}

抱歉!评论已关闭.