现在的位置: 首页 > 综合 > 正文

【字典树】 hdu1075 What Are You Talking About

2018年01月14日 ⁄ 综合 ⁄ 共 2668字 ⁄ 字号 评论关闭

What Are You Talking About

http://acm.hdu.edu.cn/showproblem.php?pid=1075



Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help
him?
 


Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains
two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single
line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new
word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single
string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 


Output
In this problem, you have to output the translation of the history book.
 


Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 


Sample Output
hello, i'm from mars. i like earth!

题意:给你一个字典,里面是一些相互对应的字符串,再给你几个长字符串,求翻译后的字符串。

题解:字典树,先把字典中的每对字符串编号,并把字符串对的前者和对应的字符串对编号放入map中方便最后输出的查找,把字符串对的后者和对应的字符串对编号放入字典树中。之后进行基本的查找即可。

#include<cstdio>
#include<string>
#include<cstring>
#include<map>
using namespace std;
struct node
{
    node *next[26];
    int id;
    node()
    {
        memset(next,0,sizeof(next));
        id=0;
    }
}*head;
map<int,string> mapt;
void build(char *s,node *head,int id)
{
    int len=strlen(s),k;
    for(int i=0; i<len; ++i)
    {
        k=s[i]-'a';
        if(head->next[k]==NULL)
            head->next[k]=new node();
        head=head->next[k];
    }
    head->id=id;
}
int ac_find(char *s,node *head)
{
    node *p=head;
    int len=strlen(s),k;
    for(int i=0;i<len;++i)
    {
        k=s[i]-'a';
        if(p->next[k])
           p=p->next[k];
        else
           return 0;
    }
    if(p->id)
      return p->id;
    return 0;
}
int main()
{
    char s[15],t[15];
    int id,l;
    scanf("%s",s);
    head=new node();
    for(int i=1;; ++i)
    {
        scanf("%s",s);
        if(strcmp(s,"END")==0) break;
        scanf("%s",t);
        build(t,head,i);
        mapt.insert(make_pair(i,string(s)));
    }
    scanf("%s",s);
    getchar();
    s[0]='\n';
    l=0;
    for(char ch;;)
    {
        ch=getchar();
        if(isupper(ch)||islower(ch))
            s[l++]=ch;
        else
        {
            s[l]='\0';
            if(strcmp(s,"END")==0) break;
            if(strlen(s)!=0)
            {
                id=ac_find(s,head);
                if(id)
                    printf("%s",mapt.find(id)->second.c_str());
                           else
                               printf("%s",s);
                           }
                   putchar(ch);
            l=0;
        }
    }
    return 0;
}

抱歉!评论已关闭.