现在的位置: 首页 > 综合 > 正文

【STL】Kiki & Little Kiki 1

2018年01月14日 ⁄ 综合 ⁄ 共 2250字 ⁄ 字号 评论关闭

Kiki & Little Kiki 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)



Problem Description
Kiki is considered as a smart girl in HDU, many boys fall in love with her! Now, kiki will finish her education, and leave school, what a pity! One day, zjt meets a girl, who is like kiki very much, in the campus, and calls her little kiki. Now, little kiki
want to design a container, which has two kinds of operation, push operation, and pop operation. 
Push M: 
  Push the integer M into the container.
Pop M:
  Find the maximal integer, which is not bigger than M, in the container. And pop it from the container. Specially, for all pop operations, M[i] is no bigger than M[i+1].
Although she is as smart as kiki, she still can't solve this problem! zjt is so busy, he let you to help little kiki to solve the problem. Can you solve the problem?

 


Input
The input contains one or more data sets. At first line of each input data set is an integer N (1<= N <= 100000) indicate the number of operations. Then N lines follows, each line contains a word (“Push” or “Pop”) and an integer M. The word “Push” means a push
operation, while “Pop” means a pop operation. You may assume all the numbers in the input file will be in the range of 32-bit integer.
 


Output
For each pop operation, you should print the integer satisfy the condition. If there is no integer to pop, please print “No Element!”. Please print a blank line after each data set.
 


Sample Input
9 Push 10 Push 20 Pop 2 Pop 10 Push 5 Push 2 Pop 10 Pop 11 Pop 19 3 Push 2 Push 5 Pop 2
 


Sample Output
No Element! 10 5 2 No Element! 2

题目就是找已给的数据中小于X的最大元素,不存在就输出No Element!。自己写可能比较复杂,曾经考虑过接收全部元素再处理的方法,没有写完。

#include<cstdio>
#include<algorithm>
#include<set>
using namespace std;
struct p
{
       int vi;
       bool operator < (const struct p &a) const
       {
            return vi<a.vi;
       }
}temp;
multiset<struct p> q;
int main()
{
    int n;
    char s[100];
    for(;scanf("%d",&n)!=EOF;)
    {
       q.clear();
       int m;
       for(int i=0;i<n;++i)
       {
               scanf("%s%d",s,&m);
               temp.vi=m;
               if(s[2]=='s')
                            q.insert(temp);
               else
               {
                           multiset<struct p>::iterator a=q.upper_bound(temp);
                           if(a==q.begin())
                              printf("No Element!\n");
                           else
                           {
                               printf("%d\n",((--a)->vi));
                               q.erase(a);
                           }
               }    
       }
       printf("\n");
    }
    return 0;
}

                            

其他一些函数

来源:http://blog.csdn.net/ACM_Ted

抱歉!评论已关闭.