现在的位置: 首页 > 综合 > 正文

【STL】Football Score

2018年01月14日 ⁄ 综合 ⁄ 共 3032字 ⁄ 字号 评论关闭

Football Score

Time Limit: 1000/1000 MS (Java/Others)     Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 254    Accepted Submission(s): 39
Problem Description
Football is one of the greatest games in the world. Lots of people like to play football. After one season of matches, the header has to calculate the last scores of every team. He is too lazy that he doesn't want to calculate, so he asks you to write a program
for him to solve the problem.


Here are the rules:

1 Every team has to match with all the other teams.

2 Every two teams have to match for two times,one at home and one away.

3 In one match, the winner will get 3 points, the loser will get 0 point. If it is draw, both of them will get 1 point.
 
Input
The input consists of many test cases. In each case, there will be a number N in the first line which means the number of teams. Followed by N * (N – 1)lines. Each line stands for a match between two teams. The format is: "Team1 VS Team2 p:q", p stands for
the balls that Team1 has kicked in and q stands for the balls that Team2 has kicked in. p and q are not greater than 9.


Process to the end of file.
 
Output
For each test case, output the teams and their scores in descending order. One line a team, the format is: "TeamX scores". If two teams get the same score, the one with high net goals will be ahead, which net goal means the difference between the total balls
that the team kicked in and the total balls that the team lost. IE: if one team kicked in 30 balls and lost 40 balls, then the net goal is 30 – 40 = -10. If two teams have the same score and the same net goal, the one whose kicked in balls is bigger will be
ahead. If two teams have the same score and the same net goal and the same kicked in balls, they will be outputed in alphabetic order.


Output a blank line after each test case.
 
SampleInput
3
Manchester VS Portsmouth 3:0
Liverpool VS Manchester 1:1
Liverpool VS Portsmouth 0:0
Portsmouth VS Manchester 1:1
Manchester VS Liverpool 2:1
Liverpool VS Portsmouth 1:2
 
SampleOutput
Manchester 8
Portsmouth 5
Liverpool 2

比较水的题目。。看看代码就懂的。。

#include<cstdio>
#include<map>
#include<string>
#include<set>
#include<algorithm>
using namespace std;
struct point
{
       string s;
       int score;
       int in;
       int out;
       bool operator < (const struct point &a) const
       {
            if(score>a.score)   return true;
            else  if(score==a.score)
            {
                  if(in-out>(a.in-a.out)) return true;
                  else if(in-out==(a.in-a.out))
                  {
                       if(in>a.in)  return true;
                       else if(in==a.in)
                       {
                            if(s<a.s) return true;
                            else  return false;
                       }
                       else  return false;
                  }
                  else return false;
            }
            else  return false;
       }
}node;
map<string,struct point> List;
set<struct point> Out;
char t1[100],t2[100];
string s1,s2;
int a,b;
int main()
{
    int n;
    for(;scanf("%d",&n)!=EOF;)
    {
         List.clear();
         Out.clear();
         for(int i=0;i<n*(n-1);++i)
         {
                 scanf("%s VS %s %d:%d",&t1,&t2,&a,&b);
                 s1=string(t1);
                 s2=string(t2);
                 node.s=s1;node.score=(a==b?1:(a>b?3:0));node.in=a;node.out=b;
                 if(List.count(s1))
                 {
                                   List[s1].score+=node.score;List[s1].in+=node.in; List[s1].out+=node.out;
                 }
                 else
                                   List.insert(make_pair(s1,node));
                 node.s=s2;node.score=(a==b?1:(a<b?3:0));node.in=b;node.out=a;
                 if(List.count(s2))
                 {
                                   List[s2].score+=node.score;List[s2].in+=node.in; List[s2].out+=node.out;
                 }
                 else
                                   List.insert(make_pair(s2,node));
         }
         for(map<string,struct point>::iterator it=List.begin();it!=List.end();++it)
                  Out.insert(it->second);
         for(set<struct point>::iterator it=Out.begin();it!=Out.end();++it)
                        printf("%s %d\n",(it->s).c_str(),it->score);
         printf("\n");
    }
    return 0;
}

来源:http://blog.csdn.net/ACM_Ted
                        
                     

抱歉!评论已关闭.