现在的位置: 首页 > 综合 > 正文

【STL】Is It A Tree?

2018年01月14日 ⁄ 综合 ⁄ 共 2195字 ⁄ 字号 评论关闭

Is It A Tree?

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 2
Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 


Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 
 


Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 
 


Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 


Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 

比较简单的做法就是记录每个点的入度,如果最后入度为1的个数不是总点数-1的话就不是树。这题体现了map的确很好用。

ps:hdu上数据结束的标志是两个数都小于0而不是题目给的-1 -1。因此TL一次啊~

#include<cstdio>
#include<map>
using namespace std;
map<int,int> in;
map<int,bool> flag;
bool check()
{
     int num=0;
     for(map<int,int>::iterator it=in.begin();it!=in.end();++it)
        if(it->second==1)   ++num;
     if(flag.size()-num==1)
        return true;
     else
        return false;
}
int main()
{
    int a,b,index=1;
    in.clear();
    flag.clear();
    for(;scanf("%d%d",&a,&b);)
    {
        if(a<0&&b<0)
            break;
        if(a==0&&b==0)
        {
                      if((flag.empty())||(check()))
                          printf("Case %d is a tree.\n",index++);
                      else
                          printf("Case %d is not a tree.\n",index++);
                      in.clear();
                      flag.clear();
        }
        else
        {
            if(in.count(b))
               in.find(b)->second++;
            else
               in.insert(make_pair(b,1));
            flag[a]=true;
            flag[b]=true;
        }
    }
    return 0;
}

来源:http://blog.csdn.net/ACM_Ted
                      

抱歉!评论已关闭.