现在的位置: 首页 > 综合 > 正文

【并查集】Wireless Network

2018年01月14日 ⁄ 综合 ⁄ 共 2323字 ⁄ 字号 评论关闭
Wireless Network

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by
one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the
communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers
xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

简单的并查集。

看着代码和注释就都懂了。

#include<cstdio>
#include<cstring>
using namespace std;
int pre[1005],dis[1005][2];
bool flag[1005];//是否已修复的标记
int Find(int x)//查找
{
    if(pre[x]==x) return x;
    return pre[x]=Find(pre[x]);
}
void Union(int a,int b)//合并
{
    pre[b]=a;
}
int main()
{
    int n,d,a,b,fai,faa;
    char s[10];
    scanf("%d%d",&n,&d);
    memset(flag,false,sizeof(flag));
    for(int i=1;i<=n;++i)
    {
        scanf("%d%d",&dis[i][0],&dis[i][1]);
        pre[i]=i;
    }
    for(;scanf("%s",s)!=EOF;)
    {
        if(s[0]=='O')
        {
            scanf("%d",&a);
            if(flag[a]) continue;
            flag[a]=true;
            for(int i=1;i<=n;++i)
            {
                fai=Find(i);faa=Find(a);
                if(flag[i]&&((dis[i][0]-dis[a][0])*(dis[i][0]-dis[a][0])+(dis[i][1]-dis[a][1])*(dis[i][1]-dis[a][1]))<=d*d)//判断电脑之间的距离和是否已经被修复
                {
                    if(fai!=faa)  Union(fai,faa);
                }
            }
        }
        else
        {
            scanf("%d%d",&a,&b);
            if(Find(a)==Find(b))
               printf("SUCCESS\n");
            else
               printf("FAIL\n");
        }
    }
    return 0;
}

抱歉!评论已关闭.