现在的位置: 首页 > 综合 > 正文

【JAVA】File Search Tool

2018年01月14日 ⁄ 综合 ⁄ 共 1801字 ⁄ 字号 评论关闭

File Search Tool

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)



Problem Description
WisKey downloaded much software in winter vacation, and the disk was in a state of confusion. He wastes many times to find the file everyday. So he wants a tool to help him do this work. 
The file name consists of lowercase letters. 
The name pattern is a string of lowercases, '?'s and '*'s. In a pattern, a '?' matches any single lowercase, and a '*' matches none or more lowercases.
Let’s do this~

 


Input
The first line of input contains two integers N (0 < N <= 10000) and M (0 < M <=100), representing the number of file names and the number of word patterns. 
Each of the following N lines contains a file name. After those, each of the last M lines contains a name pattern. 
You can assume that the length of patterns will not exceed 6, and the length of file names will not exceed 20.
There are multiple cases in the data file, process to end of file.

 


Output
For each pattern, print a line contains the number of matched file names.
If there is no file name that can match the pattern, print "Not match".

 


Sample Input
4 5 this the an is t* ?h*s ??e* *s e
 


Sample Output
2 1 1 2 Not match

import java.io.*;
import java.util.regex.*;
import java.util.*;
public class Main
{
    public static void main(String args[]) throws Exception
    {
 
        String str[]=new String[10005];
        String temp;
        Scanner cin = new Scanner (new BufferedInputStream(System.in));
        for(;cin.hasNext();)
        {
        int a=cin.nextInt(),b=cin.nextInt();
        for(int i=0;i<a;++i)
            str[i]=cin.next();
        for(int i=0;i<b;++i)
        {
            int res=0;
            temp=cin.next();
            String ss="^";
            for(int k=0;k<temp.length();++k)
            {
                if(temp.charAt(k)=='?') ss+='.';
                else if(temp.charAt(k)=='*') ss+=".*";
                else ss+=temp.charAt(k);
            }
            ss +="$";
            Pattern p=Pattern.compile(ss);
            //通过compile()方法创建Pattern实例 
            for(int k=0;k<a;k++)
            {
 
                Matcher m=p.matcher(str[k]);
                //通过match()创建Matcher实例
                booleanrs=m.find();
                if(rs) res++;
            }
            if(res==0) System.out.println("Not match");
             else System.out.println(res);
        }
        }
    }
}

来源:http://blog.csdn.net/ACM_Ted

【上篇】
【下篇】

抱歉!评论已关闭.