现在的位置: 首页 > 综合 > 正文

POJ 2115 C Looooops

2018年01月15日 ⁄ 综合 ⁄ 共 1575字 ⁄ 字号 评论关闭
C Looooops
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14193   Accepted: 3547

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming
that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop
and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the
loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

 

题目链接

 

知识点:同余方程 + 扩展欧几里得算法

 

#include<cstdio>

using namespace std;

long long num[33];

#define LL long long
#define lld	lld

LL ext_gcd(LL a,LL b,LL &x,LL &y)
{
	LL tmp,ret;
	if(!b)
	{
		x=1;	y=0;	return a;
	}
	ret=ext_gcd(b,a%b,x,y);

	tmp=x;	x=y;	y=tmp-a/b*y;
	return ret;
}

int main()
{
	LL A,B,C,k,tmp;
	LL i,j,x,y,g;

	num[1]=2;
	for(i=2;i<=32;i++)
		num[i]=num[i-1]*2;

	while(scanf("%lld%lld%lld%lld",&A,&B,&C,&k)==4 && A||B||C||k)
	{
		g=ext_gcd(C,num[k],x,y);
		if((A-B)%g==0)
		{
			tmp=x*(B-A)/g;
			tmp=(tmp%(num[k]/g)+num[k]/g)%(num[k]/g);
			printf("%lld\n",tmp);
		}
		else
			printf("FOREVER\n");
	}

	return 0;
}

 

抱歉!评论已关闭.