现在的位置: 首页 > 综合 > 正文

Hdu 4341 Gold miner

2018年01月15日 ⁄ 综合 ⁄ 共 2292字 ⁄ 字号 评论关闭

Gold miner

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1033    Accepted Submission(s): 424

Problem Description
Homelesser likes playing Gold miners in class. He has to pay much attention to the teacher to avoid being noticed. So he always lose the game. After losing many times, he wants your help.


To make it easy, the gold becomes a point (with the area of 0). You are given each gold's position, the time spent to get this gold, and the value of this gold. Maybe some pieces of gold are co-line, you can only get these pieces in order. You can assume it
can turn to any direction immediately.
Please help Homelesser get the maximum value.
 

Input
There are multiple cases.
In each case, the first line contains two integers N (the number of pieces of gold), T (the total time). (0<N≤200, 0≤T≤40000)
In each of the next N lines, there four integers x, y (the position of the gold), t (the time to get this gold), v (the value of this gold). (0≤|x|≤200, 0<y≤200,0<t≤200, 0≤v≤200)
 

Output
Print the case number and the maximum value for each test case.
 

Sample Input
3 10 1 1 1 1 2 2 2 2 1 3 15 9 3 10 1 1 13 1 2 2 2 2 1 3 4 7
 

Sample Output
Case 1: 3 Case 2: 7
 

Author
HIT
 

Source
 

Recommend
zhuyuanchen520

先预处理下后用分组背包解题预处理:假设具有相同斜率的坐标有x个,将其转化为一组物品,将离原点最近的坐标视为一个物品,

离原点最近的2个坐标也视为一个物品。。。。一直到x个。

#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>

int num[201][5];
int flag[201]; //用来标记物品属于哪个组
int f[40001]; //花费

int cmp(const void *a,const void *b)
{
    double tmp1=(double)(((int *)a)[0])/((int*)a)[1];
    double tmp2=(double)(((int *)b)[0])/((int*)b)[1];
    if(fabs(tmp1-tmp2)<0.000001)
    {
        return ((int*)a)[1]-((int*)b)[1];
    }
    else
        return tmp1>tmp2?1:-1;

}

int main(void)
{
    int N,T,t=0;
//    freopen("d:\\in.txt","r",stdin);
    while(scanf("%d%d",&N,&T)==2)
    {
        int i,j,k,max=0;
        t++;
        for(i=0;i<N;i++)
        {
            scanf("%d%d%d%d",&num[i][0],&num[i][1],&num[i][2],&num[i][3]);
            max+=num[i][2];
        }
        qsort(num,N,sizeof(num[0]),cmp);    //将具有相同斜率的坐标放在了一起,且离原点越近,排在越前
        memset(flag,0,sizeof(flag));
        int count=1;
        flag[0]=1;
        for(i=1;i<N;i++)              //对物品进行分组,且预处理物品组
        {
            double tmp1=(double)num[i-1][0]/num[i-1][1];
            double tmp2=(double)num[i][0]/num[i][1];
            if(fabs(tmp1-tmp2)<0.000001)
            {
                num[i][2]+=num[i-1][2];
                num[i][3]+=num[i-1][3];
            }
            else
                count++;
            flag[i]=count;
        }
        j=0;
        memset(f,0,sizeof(f));
        for(k=1;k<=count;k++)       //分组背包
        {
            for(i=T;i>=1;i--)
            {
                int tmp=j;
                while(flag[tmp]==k)
                {
                    if(i-num[tmp][2]>=0)
                        f[i]=f[i]>f[i-num[tmp][2]]+num[tmp][3]?f[i]:f[i-num[tmp][2]]+num[tmp][3];
                    tmp++;
                }
            }
            while(flag[j]==k)
                j++;
        }
        printf("Case %d: %d\n",t,f[T]);
    }
    return 0;
}


抱歉!评论已关闭.