现在的位置: 首页 > 综合 > 正文

LA 3644 X-Plosives

2018年01月15日 ⁄ 综合 ⁄ 共 2181字 ⁄ 字号 评论关闭

X-Plosives

 

A secret service developed a new kind of explosive that attain its volatile property only when a specific association of products occurs. Each product is a mix of two different simple compounds, to which we call a
binding pair. If N>2, then mixing N different binding pairs containing N simple compounds creates a powerful explosive.
For example, the binding pairs A+B, B+C, A+C (three pairs, three compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.

 

You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in the same room an explosive association. So, after placing
a set of pairs, if you receive one pair that might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you must accept it.

 

An example. Let’s assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G, F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the following explosive with the previous pairs: A+B, G+B, A+E, E+G (4
pairs with 4 simple compounds). Finally, you would accept the last pair, F+H.

 

Compute the number of refusals given a sequence of binding pairs.

 

Input

The input will contain several test cases, each of them as described below. Consecutive test cases are separated by a single blank line.

Instead of letters we will use integers to represent compounds. The input contains several lines. Each line (except the last) consists of two integers (each integer lies between 0 and 105) separated by a single
space, representing a binding pair. The input ends in a line with the number –1. You may assume that no repeated binding pairs appears in the input.

 

Output

For each test case, a single line with the number of refusals.

 

Sample Input

1 2

3 4

3 5

3 1

2 3

4 1

2 6

6 5

-1

 

Sample Output

3

 解题思路:把每个元素看成顶点,则一个简单化合物就是一条边,当整个图存在环的时候,组成环的边对应的化合物是危险的,反之则是安全的。

 

用并查集判断是否和存在环。

#include<cstdio>
#include<cstring>

using namespace std;

const int MAXN=100111;

int cnt[MAXN];

int find(int x)
{
	int tmp=x,a;
	while(cnt[tmp]!=tmp)
	{
		tmp=cnt[tmp];
	}
	while(cnt[x]!=tmp)
	{
		a=cnt[x];
		cnt[x]=tmp;
		x=cnt[x];
	}
	return tmp;
}

int main()
{
	int a,b,count;
	int i;

	while(scanf("%d",&a)==1)
	{
		count=0;
		if(a==-1)
		{
			printf("0\n");
			continue;
		}
		scanf("%d",&b);

		for(i=0;i<=MAXN;i++)
			cnt[i]=i;

		cnt[b]=a;

		
		while(scanf("%d",&a),a!=-1)
		{
			scanf("%d",&b);

			a=find(a);	b=find(b);

			if(a==b)
				count++;
			else
			{
				cnt[b]=a;
			}
		}

		printf("%d\n",count);
	}

	return 0;
}

 

 

抱歉!评论已关闭.