现在的位置: 首页 > 综合 > 正文

Hdu 1213 How Many Tables

2018年01月15日 ⁄ 综合 ⁄ 共 1594字 ⁄ 字号 评论关闭

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6702    Accepted Submission(s): 3208

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
2 4
 

Author
Ignatius.L
 

Source
 

Recommend
Eddy

#include<stdio.h>

int n[1001];
int h[1001];

int find(int x)
{
    int r=x,i=x,j;
    while(n[r]!=r)
        r=n[r];
    while(i!=r)
    {
        j=n[i];
        n[i]=r;
        i=j;
    }
    return r;
}

int main(void)
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int i,j,con,N,M;
        scanf("%d%d",&N,&M);
        for(i=1;i<=N;i++)
        {
            n[i]=i;
            h[i]=1;
        }
        for(i=1;i<=M;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            x=find(x);
            y=find(y);
            if(x!=y)
            {
                if(h[x]==h[y])
                {
                    n[x]=y;
                    h[y]++;
                }
                else
                    if(h[x]<h[y])
                        n[x]=y;
                    else
                        n[y]=x;
            }
        }
        con=0;
        for(i=1;i<=N;i++)
        {
            if(n[i]==i)
                con++;
        }
        printf("%d\n",con);
    }
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.