现在的位置: 首页 > 综合 > 正文

Hdu 1239 Calling Extraterrestrial Intelligence Again

2018年01月15日 ⁄ 综合 ⁄ 共 2839字 ⁄ 字号 评论关闭

Calling Extraterrestrial Intelligence Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3420    Accepted Submission(s): 1827

Problem Description
A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16, 1974. The message consisted of 1679 bits and was meant to be translated to
a rectangular picture with 23 * 73 pixels. Since both 23 and 73 are prime numbers, 23 * 73 is the unique possible size of the translated rectangular picture each edge of which is longer than 1 pixel. Of course, there was no guarantee that the receivers would
try to translate the message to a rectangular picture. Even if they would, they might put the pixels into the rectangle incorrectly. The senders of the Arecibo message were optimistic.
We are planning a similar project. Your task in the project is to find the most suitable width and height of the translated rectangular picture. The term "most suitable" is defined as follows. An integer m greater than 4 is given. A positive fraction a / b
less than or equal to 1 is also given. The area of the picture should not be greater than m. Both of the width and the height of the translated picture should be prime numbers. The ratio of the width to the height should not be less than a / b nor greater
than 1. You should maximize the area of the picture under these constraints.

In other words, you will receive an integer m and a fraction a / b. It holds that m > 4 and 0 < a / b < 1. You should find the pair of prime numbers p, q such that pq <= m and a / b <= p / q <= 1, and furthermore, the product pq takes the maximum value among
such pairs of two prime numbers. You should report p and q as the "most suitable" width and height of the translated picture.

 

Input
The input is a sequence of at most 2000 triplets of positive integers, delimited by a space character in between. Each line contains a single triplet. The sequence is followed by a triplet of zeros, 0 0 0, which indicated the end
of the input and should not be treated as data to be processed.

The integers of each input triplet are the integer m, the numerator a, and the denominator b described above, in this order. You may assume 4 < m <= 100000 and 1 <= a <= b <= 1000.

 

Output
The output is a sequence of pairs of positive integers. The i-th output pair corresponds to the i-th input triplet. The integers of each output pair are the width p and the height q described above, in this order.

Each output line contains a single pair. A space character is put between the integers as a delimiter. No other characters should appear in the output.

 

Sample Input
5 1 2 99999 999 999 1680 5 16 1970 1 1 2002 4 11 0 0 0
 

Sample Output
2 2 313 313 23 73 43 43 37 53
 

Source
 

Recommend
Eddy

m开始减少,看是否满足条件,满足条件就输出。。。!!!!!

这个更像数学题。。。。。

#include<stdio.h>
#include<math.h>

int a,b;

int is_pri(int x)
{
    int i;
    int m=(int )sqrt(x+1);
    if(x==2 || x==3)
        return 1;
    for(i=2;i<=m;i++)
    {
        if(!(x%i))
        {
            return 0;
        }
    }
    return 1;
}

int is_(int x)
{
    int i,count=0;
    int m=(int)sqrt(x+1);
    for(i=2;i<=m && count<=2;i++)
    {
        if(!(x%i))
        {
            if(is_pri(i)&&is_pri(x/i) && x/i*a <= b*i)
            {
                printf("%d %d\n",i,x/i);
                return 1;
            }
            else
                return 0;
        }
    }
    return 0;
} 

int main(void)
{
    int m;
    while(scanf("%d%d%d",&m,&a,&b),(m!=0 || a!=0 || b!=0))
    {
        int tmp=m;
        while(1)
        {
            if(is_(tmp))
                break;
            tmp--;
        }
    }
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.