现在的位置: 首页 > 综合 > 正文

HDOJ 1076 An Easy Task 计算第N个闰年(闰年的计算)

2018年01月19日 ⁄ 综合 ⁄ 共 959字 ⁄ 字号 评论关闭

An Easy Task

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14727    Accepted Submission(s): 9404

Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
 
Output
For each test case, you should output the Nth leap year from year Y.
 
Sample Input
3 2005 25 1855 12 2004 10000
 
Sample Output
2108 1904 43236

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1076

/*
给定起始年 计算第N个闰年 
*/
#include<iostream>
using namespace std;
int main(){
    int m,n,y,i,k;
    cin>>m;
    while(m--)
    {
        cin>>y>>n;
        k=0;
        for(i=y;;i++)
        {
            if((i%4==0&&i%100!=0)||i%400==0) k++;
            if (k==n) 
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}

抱歉!评论已关闭.