现在的位置: 首页 > 综合 > 正文

HDOJ 1096 A+B for Input-Output Practice (VIII) 简单求和

2018年01月19日 ⁄ 综合 ⁄ 共 750字 ⁄ 字号 评论关闭

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 101145    Accepted Submission(s): 31156

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3

Sample Output
10 15 6

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1096

/*
简单的求和 
*/
#include<stdio.h>

int main(){

int m,n,k,i,sum;

scanf("%d",&n);
while(n--)
{
    scanf("%d",&m);
    sum=0;
    for(i=0;i<m;i++)
    {
        scanf("%d",&k);
        sum+=k;
    }
    printf("%d\n",sum);    
    if (n!=0) printf("\n");
}
return 0;
}

抱歉!评论已关闭.