现在的位置: 首页 > 综合 > 正文

HDU 1969 Pie 二分法分蛋糕

2018年01月19日 ⁄ 综合 ⁄ 共 1965字 ⁄ 字号 评论关闭

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4160    Accepted Submission(s): 1680

Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This
should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327 3.1416 50.2655
/*
hdoj 1969
刚开始题目没看懂
就是n个派 给f+1个人 
只要找到面积最大的进行二分 
使总的分配派的个数 满足需求即可。
二分时按派的个数 进行二分。  

*/

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;

const double PI=acos(-1.0);
int n,f;
double a[10001];

int find(double mid)
{
    int sum=0;
    for(int i=0;i<n;i++)
        sum+=int(a[i]/mid);
    if(sum>=f+1)
        return 1;
    else 
        return 0;
}

int main()
{
    int m,i;
    double max,low,up,mid;
    
    scanf("%d",&m);
    while(m--)
    {
        scanf("%d%d",&n,&f);
        max=0;
        for(i=0;i<n;i++)
        {
            scanf("%lf",&a[i]);
            a[i]=PI*a[i]*a[i];
            max=max>a[i]?max:a[i];//最大派的面积 从这里二分 
        }
        low=0;
        up=max;
        while(up-low>1e-5)//自己尝试下精度 对否 
        {
            mid=(up+low)/2;
            if(find(mid)==0)
                up=mid;
            else 
                low=mid;
        }        
        printf("%.4lf\n",(up+low)/2);
            
    }
    return 0;
}

抱歉!评论已关闭.