现在的位置: 首页 > 综合 > 正文

HDU 1022 栈 栈的模拟

2018年01月19日 ⁄ 综合 ⁄ 共 2122字 ⁄ 字号 评论关闭

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19557    Accepted Submission(s): 7331

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes
a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves,
train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your
task is to determine whether the trains can get out in an order O2.
 
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file.
More details in the Sample Input.
Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out"
for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
Sample Input
3 123 321 3 123 312
Sample Output
Yes. in in in out out out FINISH No. FINISH
/*
1022 Train Problem I
栈的模拟 

这题太坑了 怪自己粗心 
刚开始时是没加 #include<string> 
cin地方一直报错; error C2679: 二进制“>>” : 没有找到接受“<未知>”类型的右操作数的运算符(或没有可接受的转换)
后来wrong answer找了半天发现FINISH打错了 
*/
#include<iostream>
#include<string>
#include<stack>
#include<vector>
using namespace std;
int main(){
    int i,j,n; 
    string s,d;
    stack<char> sta; //栈 
    vector<string> out;//模拟输入输出 
    while(cin>>n>>s>>d)
    {
        i=0;j=0;
        sta.push(s[i]);
        out.push_back("in");
        
        while(i<s.size())
        {
            while(!sta.empty()&&sta.top()==d[j])//和第二个相同则输出 
            {
                j++;
                sta.pop();
                out.push_back("out");
            }
            if(++i<s.size())
            {
                sta.push(s[i]);
                out.push_back("in");
            }
            else break;
        }
        if(sta.empty()){
            cout<<"Yes."<<endl;
            for(i=0;i<out.size();i++)
                cout<<out[i]<<endl;
        }
        else {
            cout<<"No."<<endl;
            while(!sta.empty())
                sta.pop();
        }
        cout<<"FINISH"<<endl;
        out.clear();
    }
    return 0;
}

抱歉!评论已关闭.