现在的位置: 首页 > 综合 > 正文

HDU 1532 Drainage Ditches 最大流

2018年01月19日 ⁄ 综合 ⁄ 共 2503字 ⁄ 字号 评论关闭

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9339    Accepted Submission(s): 4402

Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage
ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into
that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections
points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water
will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
Sample Output
50
/*
hdoj 1532 最大流
bfs找增广路,然后每找到一条就将它最大程度扩大流量,
也就是加上最小残量, 将这条路径状态改变。
直到找不到增光路,说明此时已经是最大流。 
*/

#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;

#define MAX 99999999
int n,m;
int f[201][201],pre[201],visit[201];

void max_flow()
{
    
    int t,i,temp,sum=0;;
    
    while(1)
    {
        memset(visit,0,sizeof(visit));
        memset(pre,0,sizeof(pre));
        queue<int> que;//这步很重要 开始放在上面 等于没清空 
         
        visit[1]=1;
        que.push(1);
        while(!que.empty())//一条一条的找 
        {
            t=que.front();
            que.pop();
            if(t==n) break;//找到一条增广路径跳出 
            for(i=1;i<=n;i++)
            {
                if(!visit[i]&&f[t][i]>0)
                {
                    visit[i]=1;
                    que.push(i);
                    pre[i]=t;
                }
            }    
         }
        if(!visit[n]) break;//n未标记 没找到到n的路径 结束了 跳出 
        
        temp=MAX;
        for(i=n;i!=1;i=pre[i])
        {
            if(temp>f[pre[i]][i])
                temp=f[pre[i]][i];
        }
        
        for(i=n;i!=1;i=pre[i])
        {
            f[pre[i]][i]-=temp;
            f[i][pre[i]]+=temp;
        }
        sum+=temp;
    }
    printf("%d\n",sum);
}
int main()
{
    int i,a,b,c;
    
    //freopen("test.txt","r",stdin);
    
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        
        memset(f,0,sizeof(f));
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            f[a][b]+=c;
        }
        max_flow();
    }
    return 0;
} 

抱歉!评论已关闭.