现在的位置: 首页 > 综合 > 正文

HDU 1213 How Many Tables 并查集

2018年01月19日 ⁄ 综合 ⁄ 共 1535字 ⁄ 字号 评论关闭

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15003    Accepted Submission(s): 7329

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
Sample Output
2 4
/*
HDU 1213 并查集 
*/
#include<iostream>
#include<stdio.h>
using namespace std;
int pre[1001];

int find(int x)
{
	if(x==pre[x])
		return x;
	pre[x]=find(pre[x]);
	return pre[x];
}

void Union(int a,int b)
{
	int t1=find(a);
	int t2=find(b);
	if(t1!=t2)
	{
		pre[t1]=t2;
	}
}

int main()
{
	int t,n,m,i,ans,a,b,t1,t2;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			pre[i]=i;
		ans=0;
		while(m--)
		{
			scanf("%d%d",&a,&b);
			Union(a,b);
		}
		ans=n;
		for(i=1;i<=n;i++)
		{
			if(pre[i]!=i)
				ans--;
		}
		printf("%d\n",ans);
	}
	return 0;
} 

抱歉!评论已关闭.