现在的位置: 首页 > 综合 > 正文

HDU 1563 Find your present! 找出不同的数 异或

2018年01月19日 ⁄ 综合 ⁄ 共 1123字 ⁄ 字号 评论关闭

Find your present!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2891    Accepted Submission(s): 1917

Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and
your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from
all the others.
Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.
Output
For each case, output an integer in a line, which is the card number of your present.
Sample Input
5 1 1 3 2 2 3 1 2 1 0
Sample Output
3 2

/*
HDU 1563 找出不同的数 
题目好像没说 其他的数出现偶数次 但是这里直接可以异或处理, 
*/
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int i,n,a,ans;
	while(scanf("%d",&n),n)
	{
		ans=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a);	
			ans=ans^a;
		}
		printf("%d\n",ans);
	}
	return 0;
} 

抱歉!评论已关闭.