现在的位置: 首页 > 综合 > 正文

HDU 5143 NPY and arithmetic progression DFS

2018年01月19日 ⁄ 综合 ⁄ 共 1838字 ⁄ 字号 评论关闭

NPY and arithmetic progression

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 309    Accepted Submission(s): 95

Problem Description
NPY is learning arithmetic progression in his math class. In mathematics, an arithmetic progression (AP) is a sequence of numbers such that the difference between the consecutive terms is constant.(from wikipedia)
He thinks it's easy to understand,and he found a challenging problem from his talented math teacher:
You're given four integers, a1,a2,a3,a4,
which are the numbers of 1,2,3,4 you have.Can you divide these numbers into some Arithmetic Progressions,whose lengths are equal to or greater than 3?(i.e.The number of AP can be one)
Attention: You must use every number exactly once.
Can you solve this problem?
Input
The first line contains a integer T — the number of test cases (1T100000).
The next T lines,each contains 4 integers a1,a2,a3,a4(0a1,a2,a3,a4109).
Output
For each test case,print "Yes"(without quotes) if the numbers can be divided properly,otherwise print "No"(without quotes).
Sample Input
3 1 2 2 1 1 0 0 0 3 0 0 0
Sample Output
Yes No Yes
Hint
In the first case,the numbers can be divided into {1,2,3} and {2,3,4}. In the second case,the numbers can't be divided properly. In the third case,the numbers can be divided into {1,1,1}.
/*
HDU 5143 DFS 
比赛时没看懂题目,参考别人的; 
DFS
多余3个的数可以自己成等比数列
和其他数组合成等比数列的有1,2,3,  2,3,4  1,2,3,4 三种情况
*/
#include<iostream>
#include<stdio.h>
using  namespace std;

bool check(int a,int b,int c,int d)  
{  
    
    if(a==0&&b==0&&c==0&&d==0) 
		return true;  
	//数为0,或者>=3 
    if( ((a!=0&&a>=3)||(a==0)) && ((b!=0&&b>=3)||(b==0)) && ((c!=0&&c>=3)||(c==0)) && ((d!=0&&d>=3)||(d==0)) ) 
		return true;  
  
    if(a-1>=0&&b-1>=0&&c-1>=0&&d-1>=0)  //1234
        if(check(a-1,b-1,c-1,d-1)) 
			return true;  
  
    if(a-1>=0&&b-1>=0&&c-1>=0)  //123
        if(check(a-1,b-1,c-1,d)) 
			return true;  
  
    if(b-1>=0&&c-1>=0&&d-1>=0)  //234
        if(check(a,b-1,c-1,d-1)) 
			return true;  
    return false;  
}  
int main()
{
	int t,a,b,c,d,sum;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d%d",&a,&b,&c,&d);
		if(check(a,b,c,d))
			printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
}

抱歉!评论已关闭.