现在的位置: 首页 > 综合 > 正文

HDU 1150 Machine Schedule 最小顶点覆盖

2018年01月20日 ⁄ 综合 ⁄ 共 2746字 ⁄ 字号 评论关闭

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5904    Accepted Submission(s): 2977

Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type
of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine
B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to
a suitable machine, please write a program to minimize the times of restarting machines.

 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs,
each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
3
/*
HDOJ 1150 二分图的最小匹配
很难想到与这二分图挂钩。。。

有两台机器A和B以及N个需要运行的任务。每台机器有M种不同的模式,
而每个任务都恰好在一台机器上运行。
如果它在机器A上运行,则机器A需要设置为模式xi,如果它在机器B上运行,则机器B需要设置为模式yi。
每台机器上的任务可以按照任意顺序执行,但是每台机器每转换一次模式需要重启一次。
请合理为每个任务安排一台机器并合理安排顺序,使得机器重启次数尽量少。
二分图的最小顶点覆盖数=最大匹配数

本题就是求最小顶点覆盖数的。
将两个机器的模式看做二分图,对于某一个工作的两个机器的模式连线,边就是任务,工作; 
然后求二分图的最小点覆盖(用最少的点使所有的边至少与某个点相连 最小点覆盖==二分图的最大匹配),
注意有0模式的需要忽略(因为机器的初始模式就是0)

即求二分图的最大匹配。将A,B这两台机器的模式看成(x,y)两部点集合。
即找到这些最小的点覆盖掉K个任务。
怎么想到二分图的?就是两台机器, 二分图? 
*/
#include<iostream>
#include<stdio.h>
using namespace std;
#define N 110

int vis[N],map[N][N],match[N],n,m,k;

int dfs(int u)
{
    int i;
    for(i=0;i<m;i++)//这个顶点编号从0开始,若要从1开始需要修改
        if(map[u][i]&&!vis[i])
        {
            vis[i]=1;
            
            //如果i没有匹配,或者i已经匹配了,但从match[i]出发可以找到一条增广路
            if(match[i]==-1||dfs(match[i]))
            {
                match[i]=u;
                return 1;
            }
        }
    return 0;
}

int hungary()
{
    int ans=0,i;
    memset(match,-1,sizeof(match));
    for(i=0;i<n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))
            ans++;
    }
    return ans;
}

int main()
{
    int i,u,v;
    
    //freopen("test.txt","r",stdin);
    while(scanf("%d",&n),n)
    {
        scanf("%d%d",&m,&k);
        memset(map,0,sizeof(map));
        
        while(k--)
        {
            scanf("%d%d%d",&i,&u,&v);
            if(u&&v)//初始状态为0,0的边不要加
                map[u][v]=1;
        }
        printf("%d\n",hungary());
    }
    return 0;
} 

抱歉!评论已关闭.