现在的位置: 首页 > 综合 > 正文

HDU 1068 Girls and Boys 最大独立集 二分图匹配

2018年01月20日 ⁄ 综合 ⁄ 共 1868字 ⁄ 字号 评论关闭

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7692    Accepted Submission(s): 3525

Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find
out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

 

Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
5 2
/*
HDOJ 1068 求最大独立集
求最大独立集,
公式: 最大独立集=顶点数-最大匹配/2=N-二分图最大匹配数/2 
匈牙利算法实现二分匹配:不断找增广路,扩大匹配
二分图最大独立点集=n-二分图最大匹配
因为没有说-对儿的,一定是男&&女~),
所以求出来的是最大匹配数的两倍,所以ans=n-2*最大匹配数。 
*/
#include<iostream>
#include<stdio.h>
using namespace std;
#define N 1001

int n,map[N][N],vis[N],match[N];
int DFS(int k)
{
    int i,t;
    for(i=0;i<n;i++)
    {
        if(map[k][i]&&!vis[i])//表示连通 未访问 
        {
            vis[i]=1;//标记为1之后无需标记为0回溯,因为增广路不可能再用到这个点了
            t=match[i];
            
            match[i]=k;
            if(t==-1||DFS(t))
                return 1;
            match[i]=t;
        }
    }
    return 0;
}

int max_match()
{
    int ans=0,i;
    memset(match,-1,sizeof(match));
    
    for(i=0;i<n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(DFS(i))
            ans++;
    }
    return ans;
}
int main()
{
    int i,j,a,b,c;
    
    //freopen("test.txt","r",stdin);
    while(scanf("%d",&n)!=EOF)
    {
        memset(map,0,sizeof(map));
        for(i=0;i<n;i++)
        {
            scanf("%d: (%d)",&a,&b);
            for(j=0;j<b;j++)
            {
                scanf("%d",&c);
                map[a][c]=map[c][a]=1;
            }
        }
        printf("%d\n",n-max_match()/2);    
    } 
    return 0;
}

抱歉!评论已关闭.