现在的位置: 首页 > 综合 > 正文

HDOJ 3635 Dragon Balls 并查集

2018年01月20日 ⁄ 综合 ⁄ 共 2512字 ⁄ 字号 评论关闭

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3253    Accepted Submission(s): 1255

Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical
strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the
ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
/*
hdu 并查集 
有多少颗龙珠用并查集找到结点a的根结点与根结点的秩就行了,
而龙珠a被移动的次数:
合并两个集合的过程看做第一个集合的根结点移动次数+1,
那对于任意一个结点就可以用count[a]+count[find(a)]表示a结点移动的次数,
在合并的时候由于根结点改变,所以要更新count的值。

根移动到子节点 
*/
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std; 

int f[10005],count[10005],sum[10005];
//f[x]表示x的根 count移动次数 sum龙珠数 
int find(int x)
{
    if(x!=f[x])
    {
        int t=f[x];
        f[x]=find(f[x]);//寻找x的根 
        count[x]+=count[t];//t=f[x],==> f[x]=t x的根为t 表示x移动到t
                      //表示当前x的移动次数等与它自己移动次数加根移动次数 
    }                //任意一个结点就可以用count[a]+count[find(a)]表示a结点移动的次数
    return f[x];
}

void Union(int a,int b)//a的龙珠移动到b 
{
    int x=find(a);
    int y=find(b);
    f[x]=y;                //x的根为y x==>y 
    sum[y]+=sum[x];        //y的龙珠数更新 
    count[x]++;            //x的移动次数++ 
}

int main()
{
    int t,q,n,a,b,i,ca=1;
    char str[2];
    //freopen("test.txt","r",stdin);
    
    scanf("%d",&t);
    while(t--)
    {
        
        printf("Case %d:\n",ca++);
        
        for(i=0;i<10005;i++)
        {
            f[i]=i;
            sum[i]=1;
        }
        memset(count,0,sizeof(count));//移动次数 
        
        scanf("%d%d",&n,&q);
        while(q--)
        {
            scanf("%s",str);
            if(str[0]=='T')
            {
                scanf("%d%d",&a,&b);//a的龙珠移动到b 
                Union(a,b);
            }
            else
            {
                scanf("%d",&a);
                printf("%d %d %d\n",find(a),sum[find(a)],count[a]+count[find(a)]);
            }
        }
    }
    return 0;
}

抱歉!评论已关闭.