现在的位置: 首页 > 综合 > 正文

HDOJ 1686 Oulipo KMP

2018年01月20日 ⁄ 综合 ⁄ 共 2524字 ⁄ 字号 评论关闭

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5304    Accepted Submission(s): 2124

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
1 3 0

/*
hdoj 1686 KMP
*/

#include<iostream>
#include<stdio.h>
using namespace std;

char target[10001],str[1000001];

void cal(char s[],int fun[])
{
	int len,LOLP,i,L;
	len=strlen(s);
	
	L=0;//最长前缀
	fun[1]=0;
	
	for(i=2;i<len+1;i++)
	{
		while(L>0 && (s[L]!=s[i-1]))
			L=fun[L];
		if(s[L]==s[i-1])
			L++;
		fun[i]=L;
	} 
}

int KMP(char tar[],char str[])
{
	int len1,len2,fun[10001],k,z,i;
	len1=strlen(tar);
	len2=strlen(str);
	
	cal(tar,fun);
	
	k=0;//要匹配的长度 
	z=0;
	
	for(i=0;i<len2;i++)//整个目标串长度 
	{
		while(k>0&&tar[k]!=str[i])//递归求一个匹配的 
			k=fun[k];
			
		if(tar[k]==str[i])
			k++;
		if(k==len1)//完成匹配 
		{
			z++;
			k=fun[k];
		}
	}
	return z;
}
int main()
{
	int t;
//	freopen("test.txt","r",stdin);
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%s",target,str);
		printf("%d\n",KMP(target,str));
	}
	return 0;
} 

抱歉!评论已关闭.