现在的位置: 首页 > 综合 > 正文

HDU 1198 Farm Irrigation 并查集

2018年01月20日 ⁄ 综合 ⁄ 共 2513字 ⁄ 字号 评论关闭

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5898    Accepted Submission(s): 2554

Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes,
which is marked from A to K, as Figure 1 shows.



Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map
ADC
FJK
IHE
then the water pipes are distributed like


Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.
Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?
Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the
corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
Output
For each test case, output in one line the least number of wellsprings needed.
Sample Input
2 2 DK HF 3 3 ADC FJK IHE -1 -1
Sample Output
2 3
/*
正方型的田,若相邻的田水管接口可以相连,则他们之间联通。
统计联通子图的个数。
*/
#include<iostream>
#include<stdio.h>
using namespace std;
#define N 55

int map[55][55];
int dir[4][2]={0,-1,-1,0,0,1,1,0};
int n,m,f[N*N];

int farm[11][4]={
    {1,0,0,1},
    {1,1,0,0},
    {0,0,1,1},
    {0,1,1,0},
    {1,0,1,0},
    {0,1,0,1},
    {1,1,0,1},
    {1,0,1,1},
    {0,1,1,1},
    {1,1,1,0},
    {1,1,1,1}
};


int find(int x)
{
	return f[x]!=x?f[x]=find(f[x]):f[x];
}

void merge(int x,int y)
{
	int a=find(x),b=find(y);
	if(a==b) return;
	if(a<b) f[a]=b;
		else f[b]=a;
}

int main()
{
	int i,j,k,dx,dy;
	char str[51];
	
//	freopen("test.txt","r",stdin);
	while(scanf("%d%d",&n,&m)) 
	{
		if(n==-1&&m==-1)
			break;
		
		for(i=0;i<n;i++)
		{
			scanf("%s",str);
			for(j=0;j<m;j++)
				map[i][j]=str[j]-'A';	
		}
		for(i=0;i<N*N;i++)
			f[i]=i;
			
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				for(k=0;k<4;k++)
				{
					dx=i+dir[k][0];
					dy=j+dir[k][1];
					if(dx<0||dx>=n||dy<0||dy>=m) 
						continue;
					
					if(k==0)//左边连起来 
					{
						if(farm[map[dx][dy]][1]&&farm[map[i][j]][3])
							merge(dx*m+dy,i*m+j);
					}
					else if(k==1)//上边连起来 
					{
						if(farm[map[dx][dy]][2]&&farm[map[i][j]][0])
							merge(dx*m+dy,i*m+j);
					}
					else if(k==2)//右边连起来 
					{
						if(farm[map[dx][dy]][3]&&farm[map[i][j]][1])
							merge(dx*m+dy,i*m+j);
					}
					else if(k==3)//下边连起来 
					{
						if(farm[map[dx][dy]][0]&&farm[map[i][j]][2])
							merge(dx*m+dy,i*m+j);
					}
				}
			}
		}
		int cnt=0;
		for(i=0;i<n*m;i++)
			if(f[i]==i)
				++cnt;
		printf("%d\n",cnt);
	}
	return 0;
}

抱歉!评论已关闭.