现在的位置: 首页 > 综合 > 正文

HDU 1241 Oil Deposits DFS无回溯 求油田的个数

2018年01月20日 ⁄ 综合 ⁄ 共 1901字 ⁄ 字号 评论关闭

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12195    Accepted Submission(s): 7087

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
Sample Output
0 1 2 2
/*
HDU 1241 DFS
m * n的区域,@表示一个油槽,相连的@(包括八个方向)组成一个油田,
求油田的个数
*/

#include<iostream>
#include<stdio.h>
using namespace std;

int m,n;
char map[101][101];
int dir[8][2]={0,1,0,-1,1,0,-1,0,1,1,1,-1,-1,1,-1,-1};

void DFS(int a,int b)
{
    int i,x,y;
    map[a][b]='*';
    for(i=0;i<8;i++)
    {
        x=a+dir[i][0];
        y=b+dir[i][1];
        if(x>=0&&x<m&&y>=0&&y<n&&map[x][y]!='*')
        {
            map[x][y]='*';
            DFS(x,y);
        }
    }
}

int main(){
    
    int i,j,count;
    while(scanf("%d%d",&m,&n))
    {
        if(m==0) break;
        for(i=0;i<m;i++)
            scanf("%s",map[i]);//这里用%c不好 还要处理换行符 
        count=0;
        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
            {
                if(map[i][j]=='@')
                {
                    DFS(i,j);
                    count++;
                }
            }
        printf("%d\n",count);   
    }
    return 0;
}

抱歉!评论已关闭.