现在的位置: 首页 > 综合 > 正文

HDU 1548 A strange lift 固定电梯上下楼 BFS

2018年01月20日 ⁄ 综合 ⁄ 共 2058字 ⁄ 字号 评论关闭

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11691    Accepted Submission(s): 4440

Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will
go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there
is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2
th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
Sample Input
5 1 5 3 3 1 2 5 0
Sample Output
3
/*
BFS 广搜 注意不要重复 否则相同UP 循环了 

*/

#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;


struct node{
    
    int x,step;
    node(int x1=0,int step1=0):x(x1),step(step1){};
};
int map[201],visit[201];

int a,b,n;


int BFS() 
{
    queue<node> que;
    node start,next;
    
    memset(visit,0,sizeof(visit));
    
    que.push(node(a,0));
    visit[a]=1;
    
    while(!que.empty())
    {
        start=que.front();
        que.pop();
        if(start.x==b)
            return start.step;
            
        next.step=start.step+1;
        
        next.x=start.x+map[start.x];
        if(next.x>0&&next.x<=n&&!visit[next.x])//向上 
        {
            que.push(next);
            visit[next.x]=1;
        }
        
        next.x=start.x-map[start.x];
        if(next.x>0&&next.x<=n&&!visit[next.x])//向下 
        {
            que.push(next);
            visit[next.x]=1;
        }    
        
    }
    return -1;
    
}
int main(){
    
    
    int i,ans;
    while(scanf("%d",&n)&&n)
    {
        scanf("%d%d",&a,&b);
        for(i=1;i<=n;i++)
            scanf("%d",&map[i]);        
        ans=BFS();
         
        printf("%d\n",ans); 
    }
    return 0;
}

抱歉!评论已关闭.