现在的位置: 首页 > 综合 > 正文

HDU 1063 Exponentiation 浮点数的幂次方

2018年01月20日 ⁄ 综合 ⁄ 共 2204字 ⁄ 字号 评论关闭

Exponentiation

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6738    Accepted Submission(s): 1880

Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.
This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result
is an integer.
Sample Input
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
Sample Output
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
/*
1063 Exponentiation
大数计算 浮点数 
*/
#include<iostream>
using namespace std;

int bignum[1001];
void MulBigNumber(int a[],int n)
{
    int i,z;
    z=0;
    for(i=1;i<=a[0];i++)
    {
        a[i]=a[i]*n+z;
        z=a[i]/10;
        a[i]%=10;
    }
    while(z)
    {
        a[i++]=z%10;
        z/=10;
    }
    a[0]=i-1;
    //printf("%d ",a[0]);
}

void output(int pos)
{
    int i,j;
    if(bignum[0]>pos) //总的位数大于小数的位数 
    {    
        i=bignum[0];//最高位 
        for(j=0;j<bignum[0]-pos;j++,i--) //输出小数之前的整数部分 
            printf("%d",bignum[i]);
        
        j=1;
        while(bignum[j]==0)  //去除小数点最后部分的0 
            {
                bignum[j]=-1;
                j++; 
            } 
                
        if(bignum[i]==-1||i==0) return; //没有小数部分了     
        printf(".");
        
        for(;bignum[i]!=-1&&i>=1;i--)
            printf("%d",bignum[i]);
    }
    else 
    {
        printf(".") ;//小数点前导0 不用输出 
        for(i=0;i<pos-bignum[0];i++)//满足小数点的个数 
            printf("0") ;
        j=1;
        while(bignum[j]==0)  //去除小数点最后部分的0 
            bignum[j++]=-1;
        for(i=bignum[0];bignum[i]!=-1&&i>=1;i--)
            printf("%d", bignum[i]) ;
    }
    
}    

int main(){
    
    int i,num,pos,n;
    char str[10];
    while(scanf("%s%d",str,&n)!=EOF)
    {    
        num=0;
        pos=5;
        for(i=0;i<6;i++)
        {
            if (str[i]=='.') pos=i;
                else num=num*10+str[i]-'0';
        }
        
        pos=(5-pos)*n;    //阶乘之后小数的位数 
        bignum[0]=bignum[1]=1;    //[0] 表示的是位数 
        while(n--)
            MulBigNumber(bignum,num);

        output(pos);
        printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.