现在的位置: 首页 > 综合 > 正文

HDU 1212 Big Number 大数求余数

2018年01月20日 ⁄ 综合 ⁄ 共 1002字 ⁄ 字号 评论关闭

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4522    Accepted Submission(s): 3129

Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
Output
For each test case, you have to ouput the result of A mod B.
Sample Input
2 3 12 7 152455856554521 3250
Sample Output
2 5 1521
/*
HDU 1212 Big Number (大数的余数)
看别人的 
举个例子,1314 % 7= 5
1314= ((1*10+3)*10+1)*10+4
所以有
1314 % 7= (((1 * 10 % 7 +3 )*10 % 7 +1)*10 % 7 +4)%7
*/
#include<iostream>
#include<cstring>
using namespace std;

int main(){
    
    int i,num,pos,n;
    char str[1001];
    while(scanf("%s%d",str,&n)!=EOF)
    {    
        num=0;
        for(i=0;i<strlen(str);i++)
        {
            num=(num*10+str[i]-'0')%n;
        }
        printf("%d\n",num);
    }
    return 0;
}

抱歉!评论已关闭.