现在的位置: 首页 > 综合 > 正文

HDU 1222 Wolf and Rabbit 约瑟夫环问题

2018年01月20日 ⁄ 综合 ⁄ 共 1171字 ⁄ 字号 评论关闭

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5386    Accepted Submission(s): 2697

Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are
signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2 1 2 2 2
Sample Output
NO YES
/*
1222 Wolf and Rabbit

对于狼来说,他能进的洞是(m*i)%n,i是奔跑的次数。
如果i为n,则可遍历任意的洞,m=0,1,2...
则要寻找m*i%n==0 即还没有遍历完剩余的洞 就有重复的出现

则设k=gcd(n,m),y不等于1
走n/k步 则可重复 
 m*(n/k)%n==0            
*/
#include<iostream>
using namespace std;

int gcd(int m,int n)//n>m
{
    int t;
    while(m)
    {
        t=n%m;
        n=m;
        m=t;
    }
    return n;
}
int main(){

    int n,t,p,q,m,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n); 
        if(gcd(m,n)>1)     
            printf("YES\n");
        else printf("NO\n");            
    }
    return 0;
}

抱歉!评论已关闭.