现在的位置: 首页 > 综合 > 正文

HDU/HDOJ 4004 2011大连赛区网络赛 D题

2018年01月20日 ⁄ 综合 ⁄ 共 1697字 ⁄ 字号 评论关闭

 

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 133    Accepted Submission(s): 70

Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river
is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they

are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.

Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
6 1 2 2 25 3 3 11 2 18
 

Sample Output
4 11
 

Source
 
这个题因为要求最小的最大
很明显应该用二分答案的方法。
关键是判断部分,如果直接暴力判断是二重循环。
这里可以用upper_bound函数把复杂度降下来。
 
二分+贪心判定
 
我的代码:
#include<stdio.h>
#include<algorithm>

using namespace std;

int a[500005];
int n,m,l;

bool judge(int x)
{
	int pos=0,cnt=0,id;
	while(cnt<m)
	{
		cnt=cnt+1;
		pos=pos+x;
		id=upper_bound(a+1,a+1+n,pos)-(a+1);
		pos=a[id];
		if(pos==l)
			return true;
	}
	return false;
}

int main()
{
	int i,left,right,mid,ans;
	while(scanf("%d%d%d",&l,&n,&m)!=EOF)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		a[n+1]=l;
		n=n+1;
		sort(a+1,a+1+n);
		left=0,right=l;
		while(left<=right)
		{
			mid=(left+right)>>1;
			if(judge(mid))
			{
				right=mid-1;
				ans=mid;
			}
			else
			{
				left=mid+1;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

抱歉!评论已关闭.