现在的位置: 首页 > 综合 > 正文

HDU/HDOJ 1709 The Balance HDU 2007-Spring Programming Contest

2018年01月20日 ⁄ 综合 ⁄ 共 1505字 ⁄ 字号 评论关闭

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2461    Accepted Submission(s): 977
Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S].
S is the total quality of all the weights.
 
Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N),
indicating the quality of each weight where 1<=Ai<=100.
 
Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 
Sample Input
3
1 2 4

3

2 1

9

 
Sample Output
0

2

5

4

 
Source
 
又是一道关于母函数的题目。
之前没有什么思路,看了白白屋写的代码,发现还是挺好理解的
然后自己理解了之后就动手敲了下。
先开始莫名其妙的WA了,后来发现是前面初始化的时候变量没搞对
代码:
#include<stdio.h>
#include<math.h>
#include<stdlib.h>

int c1[10005],c2[10005];
int a[105],ans[10005];

int main()
{
	int i,j,n,sum;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum=sum+a[i];
		}
		for(i=0;i<=sum;i++)
		{
			c1[i]=0;
			c2[i]=0;
		}
		c1[0]=1;
		for(i=1;i<=n;i++)
		{
			for(j=0;j+a[i]<=sum;j++)
			{
				if(c1[j]==1)
				{
					c2[j]=1;
					c2[j+a[i]]=1;
					c2[abs(j-a[i])]=1;
				}
			}
			for(j=0;j<=sum;j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		int num=0;
		for(i=1;i<=sum;i++)
		{
			if(c1[i]==0)
				ans[num++]=i;
		}
		if(num==0)
		{
			printf("0\n");
			continue;
		}
		printf("%d\n",num);
		for(i=0;i<num-1;i++)
			printf("%d ",ans[i]);
		printf("%d\n",ans[num-1]);
	}
	return 0;
}

抱歉!评论已关闭.