现在的位置: 首页 > 综合 > 正文

HDU/HDOJ 1398 Square Coins 母函数

2018年01月20日 ⁄ 综合 ⁄ 共 1443字 ⁄ 字号 评论关闭

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3600    Accepted Submission(s): 2458

Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ...,
and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

Sample Input
2 10 30 0
 

Sample Output
1 4 27
 

Source
做法:仍然是最基本的母函数,只需要把完全平方数事先预处理存起来即可
我的代码:
#include<stdio.h>
#include<string.h>

int squre[18];
int c1[305],c2[305];

void init()
{
	int i;
	for(i=1;i<=17;i++)
		squre[i]=i*i;
}

int main()
{
	int n,i,j,k;
	init();
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		for(i=0;i<=n;i++)
		{
			c1[i]=1;
			c2[i]=0;
		}
		for(i=2;i*i<=n;i++)
		{
			for(j=0;j<=n;j++)
				for(k=0;k+j<=n;k=k+squre[i])
					c2[k+j]=c2[k+j]+c1[j];
			for(j=0;j<=n;j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		printf("%d\n",c1[n]);
	}
	return 0;
}

抱歉!评论已关闭.