现在的位置: 首页 > 综合 > 正文

hdu 1114 Piggy-Bank

2018年01月20日 ⁄ 综合 ⁄ 共 3318字 ⁄ 字号 评论关闭

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12277    Accepted Submission(s): 6208

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has
any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay
everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled
with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency.
Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total
weight. If the weight cannot be reached exactly, print a line "This is impossible.".
 

Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 
/*题解: 
完全背包类问题,有略有些不同,完全背包一般是在固定容量的基础上求最大值。
而本题,是在满足固定容量的基础上求最小值。dp[0-t]要事先赋值,然后,将
dp[j] = max(dp[j],dp[j-v[i]]+val[i]);改为dp[j] = min(dp[j],dp[j-v[i]]+val[i]);即可。 

完全背包与01背包滚动数组求法的区别:
完全:  j: v[i]--->n
01:     j: v-------->0
*/

// =====================================================================================
// 
//       Filename:  Piggy-Bank.cpp
//    Description:  Piggy-Bank
//      Algorithm:  Completely backpack
//         Status: 	RunTime:62 MS 	RunMemory:248 KB
//        Version:  Dev-C++ 5.5.3 
//        Created:  2014/9/12 00:09 
//       Revision:  none
//       Compiler:  GUN C++
//         Author:  Tip of the finger melody, 1466989448@qq.com
//        Company:  none
//
// =====================================================================================

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[10010];
int main()
{
	int T,n,a,b,t,val[1010],v[1010],i,j;
	scanf("%d",&T);
	while(T--){
		memset(dp,0,sizeof(dp));
		scanf("%d %d",&a,&b);
		t=b-a;
		scanf("%d",&n);
		for(i=1; i<=n; i++)
		{
			scanf("%d %d",&val[i],&v[i]);
		}
		for(i=1; i<=t; i++)//初始化
			dp[i] = 1000000000;
		for(i=1; i<=n; i++)
		{
			for(j=v[i]; j<=t; j++)
			{
				dp[j] = min(dp[j],dp[j-v[i]]+val[i]);
			}
		}
		if(dp[t]!=1000000000)
		printf("The minimum amount of money in the piggy-bank is %d.\n",dp[t]);
		else
		printf("This is impossible.\n");
	}
}
【上篇】
【下篇】

抱歉!评论已关闭.