现在的位置: 首页 > 综合 > 正文

HDU 1217 Arbitrage 【Floyd + map】

2018年01月21日 ⁄ 综合 ⁄ 共 2459字 ⁄ 字号 评论关闭

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4849    Accepted Submission(s): 2211

Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys
10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

 

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within
a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name
cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
 

Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 

Sample Output
Case 1: Yes Case 2: No
/*
题解:Floyd算法,判断所有情况中是否有1单元的物品经过兑换后价值大于1单元
注意:STL中map的应用使对字符串的处理更加简单。
    map<string,int>mp;
    mp[string]=int;  
*/ 
#include<cstdio>
#include<map>
#include<iostream>
using namespace std;
double s[30][30];
int floyd(int n)
{
    int i,j,k;
    for(k=1; k<=n; k++)
    {
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(s[i][j]<s[i][k]*s[k][j])
                    s[i][j]=s[i][k]*s[k][j];
            }
        }
    }
    for(i=1; i<=n; i++)
    {
        //printf("--*%lf\n",s[i][i]);
        if(s[i][i]>1.0) return 1;
    }
    
    return 0;
}
int main()
{
    int i,j,n,m,k=0;
    double rate;
    char str[20],str1[20],str2[20];
    while(scanf("%d",&n)&&n)
    {
        map<string,int>mymap;
        for(i=1; i<=n; i++)
        {
            scanf("%s",str);
            mymap[str]=i;
        }
        memset(s,0,sizeof(s));
        scanf("%d",&m);
        for(i=1; i<=m; i++)
        {
            scanf("%s %lf %s",str1,&rate,str2);
        //    printf("--%d %d\n",mymap[str1],mymap[str2]);
            s[mymap[str1]][mymap[str2]]=rate;
        }
        printf("Case %d: ",++k);
        if(floyd(n))
        {
            printf("Yes\n");
        }
        else printf("No\n");
    }
    return 0;
}

抱歉!评论已关闭.