现在的位置: 首页 > 综合 > 正文

HDU 2988 Dark roads 【最小生成树】

2018年01月21日 ⁄ 综合 ⁄ 共 2072字 ⁄ 字号 评论关闭

Dark roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 639    Accepted Submission(s): 275

Problem Description
Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian
Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way,
that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?

 

Input
The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000
and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads
in each test case is less than 231.
 

Output
For each test case print one line containing the maximum daily amount the government can save.
 

Sample Input
7 11 0 1 7 0 3 5 1 2 8 1 3 9 1 4 7 2 4 5 3 4 15 3 5 6 4 5 8 4 6 9 5 6 11 0 0
 

Sample Output
51
/*题解:
    最小生成树,使用并查集求出总花费-将所有交叉点连通的路的长度(即使用路灯的花费) 
*/  
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int pre[200002];
int find(int x)
{
    return x==pre[x]?x:pre[x]=find(pre[x]);
}
int join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
    {
        pre[fx]=fy;
        return 1; 
    }
    return 0;
}
struct edge
{
    int from;
    int to;
    int d;
}e[200002];
int cmp(edge a,edge b)
{
    return a.d<b.d;
}
int main()
{
    int n,m,i,j,total,s;
    memset(e,0,sizeof(e));
    while(scanf("%d %d",&n,&m)&&(n+m))
    {
        memset(pre,0,sizeof(pre));
        memset(e,0,sizeof(e));
        for(i=0; i<n; i++) pre[i]=i;
        for(i=0,total=0; i<m; i++)
        {
            scanf("%d %d %d",&e[i].from,&e[i].to,&e[i].d);
            total+=e[i].d; 
        }
        sort(e,e+m,cmp);
        for(i=0,s=0; i<m; i++)
        {
            if(join(e[i].from,e[i].to))
            {
                s+=e[i].d;
            }
        }
        printf("%d\n",total-s);
    }
    return 0;
} 

抱歉!评论已关闭.